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Introduction

There is a new and elegant way to create queries and ad-hoc reports on your Baan data:
bQuery-Tool. This Baan session comes with an easy to use graphical interface which allows
you to create dynamic queries from your Baan database.

( Picka Q ) ( Chose a table ]
2 ICK a Quer
"mum Baan Query Tool 3.0 [550] Y ¥ - 9
File Query Field Data Output Help I /
Queries for user bsp: / / Table |Cd818041 "éles Order Lines
|
|naz-sales V L] Search lodat \
l item Item orno Sales Orde‘\‘\\\\\\\\[ AI
odat Order Date pono Position Number . .
cuno Customer cuno Customer Use to qUICkly find your
n Customer Name drct Direct Delivery table

o/ o Sales Order < item Item
Country cntr Container
Amount Item Category
Currency E& Product Variant
l Query Selected Fields | Rate > | . St
Y Amount in USD Add a field to

ccll big or small
ccl2 Conditional

rice

Remove field e Unit

from query cvps Conversion Factor Price to Inve
i citg Item Group -
< | m J »

I Query code: BQO000000000037

Change fields order Print Query
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1 Make a Query

1.1 Create a new Query

In bQuery-Tool you can create a query that display a table, with the field you want, from

one or more tables in the database.

To create a Query in bQuery-Tool:

1) You need to open bQuery-Tool session, If you don’t know how ask your administrator

2) The following screen will be displayed:

[laua Baan Query Tool 3.0 [550) e ey T
File Query Field Data Output Help
Queries for user bsp:
ftest ~|
Query code:  BQ000000000183
Down | W

Table >

Search |

To start working in a new Query click on menu bar: Query -> New and insert a query name

3) Now you have a new query with a new name

4) You can view all your queries from this drop down control under Queries for user<username>
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1.2

1.3

1.4

1.5

asm Baan Query Tool 30 [550]

File Query Field Data Output Help

Queries for user bsp: Table 3
test =l Search
Ehab-BigCustomers (N

Maintenance customers 1

Worth Trying customers

Pricing

Delete Query

You can delete the query you created by loading the query and click on menu: Query ->
Delete

Rename a Query

You can rename the query you created already by loading the query and clicking on
menu: Query -> Rename, insert a new name and click ok

Organize Queries
You can organize order of the queries viewed in the list.

Add Fields to Query

Now after you have created a new query, you are ready to add fields to it.
To add fields to query:

1) Choose the table
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Find icon to quickly find
vour table

If you have the table name insert it on the table field, if not click on find icon and a selection
window appears:

sem B2anQ 3.0 [550] \Select Table [E=REEE=|

Display All Tables P ook |

Display Tables by Description i
Display Current Query Tables

“Display All Tables” will go to the standard Baan session “Display Tables”

“Display Tables by Description” will open a new window that will allow searching for the
table by description and table code

“Display Current Query Tables” will display only the tables that are used in the current
query.

For example if we click on Display Tables by Description, a window like this appears, in
Search field we insert “Sales order”
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Search kales order|

tdltcl0é
tdsls038
tds1s040
tdsls041
tdsls042
tdsls043
tds1ls044
tdsls047
tds1s049
tds1s050
tds1s051
tdsls701
tdsls703

Sales Orders (LIC)

Sales Order Margin Control Log File

Sales Orders
Sales Order Lines
Specific Addresses (Sales Orders)

Bill of Lading Data (Sales Orders)

Unblocked Sales Orders
Sales Order Bills of Material

Delivered Sales Orders to be Processed

Sales Order History
Sales Order Line History

Sales Order Code Assi

Sales Order Acknowledgments Codes

Select a table from the list and click Ok

2) Add fields

Add the fields you want from the table, by selecting the field and click the add button

(marked in red)

[Ele Query Field Data Output Help

Queries for user bsp:

Table F:iir.mool > Items

|Query2

Search ]

Query code:

| |

BQ000000000184

item
dsca
dscb
dscc
dscd
wght
seak
seab
kitm
citg
ctyp
csel
csig
cvat
txta

Item
Description

sl

Standard
Weight

Search Key I
Search Key II
Item Type
Item Group
Product Type
Selection Code
Signal Code
Tax Code

Item Text

<
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You can also find fields without knowing the 4 letter code. You can simply search for
a certain field using the “Search” that performs a search on both the field name and
field description.

As an example, if we want to add the Delivery Date for a sales order line but are not
sure of the name of the field, we can simply search for “Date” as below and the only
fields that contain “Date” in their names will appear, making our life easier in
choosing a field.

S Baan Query Tool 30 [550 [ (s
File Query Field Data Output Help
Queries for user bsp: Table ItiitmOOl > ltems I
IQueryZ L] Search |
iten  Item -
dsca Description dsca Description EI
dscb Material dscb Material
kitm Item Type dscc Size
citg Item Group 3 dscd Standard
cwar Warehouse l ;I wght Weight
seak Search Key I
seab Search Key II
>
citg Item Group
ctyp Product Type
csel Selection Code
csig Signal Code
cvat Tax Code
txta Item Text
< "

Query code: BQ000000000184

Down | w |
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1.6 Printing a simple Query

Queries created can be printed to Baan devices. The following is an example of printed a
simple query.

1) To Print a Query, press “Print Result”

 mum Baan Query Tool 3.0 [550]

[File Query Field Data Output Help
Queries for user bsp: Table [m» ltems
|query2 Search [date

lcod  Last Counting Date

dsca Description ltdt Last Inventory Transaction Date
dscb Material umer Update Method E-Item Relation
kitm Item Type fodt First Allowed Order Date

citg Item Group auso Update Inventory/Order Data

cwar Warehouse ltpp Last Purchase Price Transaction D
1ltsp Last Sales Price Transaction Date
ltcp Last Cost Price Transaction Date

Query code: BQ000000000184

[ T

2) A windows like this appears (Query Form)

== Bon Query Too! 30 [550] - Prin

ftem | - fezzzzzzzzzzzzzz Continue

Description | - : d Cancel
Material I = Ilzzzzzzz Save Defaults
ftemType  |pyrchased ~| - |subcontracting ~] Clear Defaults

tem Group | - |fezzzzz

Warehouse | |z 722
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3) Click Continue button and you get the option to choose a device

: : Select Device o)
file Edit Group Workflow Options Order Tools Special Help '
a|n|§| n|§u|%|n?u| u||<|4|>|n e <« [ ori| T [n?] |

Device IE » Display

Driver

Type Screen

Paper Type

Page Width 80 Preview ]

Template Code | »

oware | |

Date [ Time 0:00

Copies [ 1

From Page | 1 To Page |EEEEER)

Paper Type | >

o 4

Paper Width 0 Orientation

Margin [0 Banner r

[
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The Query Form and the Query Report output can be customized to enable greater

possibilities and flexibility as we can see in the following chapters.

Add Enumeration, Text and Array Fields

bQuery-Tool supports working with Enumerated fields and Text fields and array fields,
unlike non-Baan query and reporting tools that do not recognize these fields.

As an example, if you add field tiitm001.kitm (Item Type) to your query, bQuery-Tool
recognizes this as an enumerated field. In the Form, you will be able to choose between
Manufactured, Purchased and so on. In the report output, these values will appear
instead of the number (between 1 and 6).

To

Item

IZZZZZZZZZZZZZZZZ

Description I

- ez
|

Material

IZZZZZZZZ

Item Type
Item Group

Warehouse l [Generic

Cost
| |Service

Manufactured

- [subcontracting

[zzzzzz

[zzz

If we choose a field that is a Text field, the text that is associated will be printed in the
guery report (and not the “text number”).

wsm Display Browser -

File Options Help

SIS

Manufactured 12625 |Hodel D 301

Generic 13695 |Generic computers 301

Manufactured 14650 [Model Cheetah 301

Manufactured FPS i
Item Text —
There is a new and elegant way to create queries and ad-hoc reports
from within Baan or ERP Ln: Baan Query Tool.
The webinar will include a live demo to show how easy it is to create
queries using Baan Query Tool's strong integration with Baan, and
dealing with some of the special features of the Baan data. The easy to
use graphical user interface will be demonstrated, while data is
exported to Excel templates where further calculations and summery
reports can be automatically generated.

Manufactured 14668|Hodel Panther 301

Manufactured 14665 |Model Tiger 101

HManufactured 14670 |Model Linx 301

Hanufactured 24786 |Monitor 15" LCD 201

HManufactured 24781 |Monitor 21" .32 DPI 201

Purchased 25812 |4mb 72pin simm mem 1x36-66ns 101

Furcnaseu 25814|8nb 72pin sinm mem 2x36-66ns 101

[|

Page 1
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You can also chose a field that is an array and bQuery-Tool will let you print a specific range of

each value of the array

Customer No.
Status

Turnover

Array will also be visible in output results

| Customer Name |

From

I

999999999999999.9999

| Continve |
Jezzz22 Cancel |
2222222222222222222222:) Save Defaults

099999999999999.9999

I—999999999999999. 9999

I999999999999999. 9999

|—999999999999999. 9999

I999999999999999. 9999

I—999999999999999. 9999

I999999999999999. 9999

|—999999999999999. 9999

I999999999999999. 9999
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1.7 Add Fields from a second Table (Table Linker)

In the same query you can add fields from more than one table, and link these tables
together using a common field that you can select whenever a field from another table
is added.

After you added fields from the first table to your query, you can add fields from
another table by these steps:

1) Find the second table that you wish to have fields from it
2) After you have the table selected, add fields to query and a window will be opened

I — PSR |

2
=um BaanQ 3.0 [550] - Add Table Link

Table already added

[

before

Table you want to L Insert link fields:
link —

T [tiitm001l »

3) Specify a field from both tables that is common for both of them to establish the link using
it. You can browse tables already linked in this query, and browse field inside the selected
table

w BaanQ 3.0 [550] - Select Table | = | B % |

tdsls041
tiitm001
tdsls040
tccom010

Sales Order Lines
Items

Sales Orders
Customers

Ok I Cancel

Tables browse

4) After this you can add any field from this second table

Note: You can repeat this by adding a third or more tables to query
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To view or maintain a link between two tables in the query:

On menu click: Query -> Table Linker

g
ssia BaanQ 3.0 [550] - Table Linker o8] %

Tables' links:

tdsls040.cuno = tdsls041.cuno

tccom0l0.cuno = tdsls04l.cuno Link Ty pe
tiitm00l.item = tdslsO4l.item M|

Descriptions:
(Sales Orders).Customer = (Sales Order Lines).Customer

The possible actions for each link are the following:

- Add Link — add another link to query (same as we did above)
- Link Type — Change an already existing link with 3 link types available:

[ & Baanq 20 5501 - LinkTypl (= [=] =)

(¢ 1: Only include rows where the joined fields from both tables are
equal.

(" 2: Include All records fromtable tiitm001 and only those records
fromtable tdsls041 where the joined fields are equal.

(" 3: Include All records fromtable tdsls041 and only those records
fromtable tiitm001 where the joined fields are equal.

0K Cancel

- Remove Link — we can remove already exists link from this query

Example:

We want to create a query that displays Sales Orders lines with customer name and
Iltem description with price and quantity for each line

In order to display all this information we need to link 3 tables together:
- tdsls041 — That contains Sales order Lines.
- tccom010 - that we will link to in order to get customer name
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- tiitm001 — we link this table to get item description

Here is an example of the query in bQuery-Tool (To view field details on menu click: View ->

View Fields Details):

— ] E ]

File Query Field Data Output Help

M’m@rwﬁﬁﬂ? T —— ™

Queries for user bsp:

|Customers Orders

tdsls041.cuno
tiitm001.dsca
tdsls040.creg
tccom010.nama
tccom010.cnpa
tccom010.refp
tccom010.mail
tccom010.telp

Customer

Description

Area

Name

Customer Status
Purchasing Reference
Email

Telephone

Query code: BQ000000000084

oown | w |

Print Results for this query:

[
[

Table Euou » Sales Order Lines

.

Search |

lorno Sales Order a
[pono Position Number

cuno Customer

drct Direct Delivery

item Item

cntr Container

jopol Item Category

cpva Product Variant

sdsc Standard Description

pric Price

stpr Structure Price

iplev Price Level

cups Sales Price Unit

cvps Conversion Factor Price to Inve
citg Item Group ~
[ FR— | 3

Print Result I
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1.8 Add Calc. fields

In bQuery-Tool, we can define formulas that calculate a result from table fields and
other formulas.

To create a new formula and add it to a query:

1) On menu click: Field -> Add Calculated Field

T

o
wiim BQT 3.0 [550] - Calculated Field =lE] =2

- Layout

|| FieldName  [££13

Description  |Formula - 13

Data Type Long v Format »

Column width [0_
Alignment [R.gm—z
- Formula
(I V= | k)
[ =
(I [ =l »)

- Opti

p

[V Include fieldin form [V Include field in result

Add Cancel

Form fields:

a. Column name — name of formula field. Default is generated by BQT.
b. Column Description — Description of column, as it will be displayed in the report.

c. Column Type — Data Type of the formula field: Possible values are Date, Long,
Double, String

d. Column Width — specify the column width as it will be displayed in the report.

e. Column alignment — formula alignment in report. Options are: Default, Center,
Right and Left
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f.  Column format — formula format. You can chose from a list of formats that are
supported in your Baan system. Sample expression of 1234.00 (or 1234,00) is
displayed to ease the choice of the format.

—
mum BaanQ 2.8 [550] - Select Format
001: 1234.00 i
002: 1234.00
003: 1234.00 3
004: 1234.0000
005: 1234.00
il |ooe: 1234.00
[ |o07: 1234.0000
008: 1234.00
I |oos: 1234.000000
010: 1234.00
020: 1234.0000
021: 1234.00
095: 1,234.00
096: 1,234.00
400: %
710: % 4
ram. o | ]
Ok Cancel
L — ——

2) Specify the formula
Formulas may include 2, 3 or 4 fields.
<Field1> <Operator> <Field2>
Or

(<Field1> <Operator> <Field2>)
<Operator>
(<Field3> <Operator><Field4>)

Operators supported are +, -, *, /

Example of a formula:
We want to display all the items we have in database, with their Material Cost and
Standard Cost and also to create another formula to calculate the percentage of

material in the Standard Cost.

The formula is (Material Cost / Standard cost) * 100
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Table we will use is ttitm001.The Query is the following:

Material/Standard

Query code:  BQ000000000100

(=Dl

n B2 Tool 30 le[@[ =]
aizan Quey Tool 30 - - —

File Query Field Data Output Help

Queries for user bsp: Table F:iir.maol P ltems

Jitem with Text 1=l Search [standard

tiitmo0l.item  Item dscd  Standard

tiitm00l.kitm  Item Type 3 Standard Cost Price

tiitm001.dsca Description potc Standard Potency

tiitmo0l.matc  Material Costs

tiitm00l.copr  Standard Cost Price

tds1s04l.orno  Sales Order =]

Formula named: Material / Standard

e BQT 3.0 [550) o EE =
mum BQT 3.0 [550] - Calculated Field e =

l - Layout
FieldName  [££7

Description |For|mla -7
Data Type ILong 'I Format I »
Column width Io

Alignment Left -

- Formula

(feiiemool.mate P ~] [eiitmool.copr *)
I' VI

(Jroo [ »)

- Options
¥ Include field in form [V Include field in result

_ ok | _cance |
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Now output results will be like this:

File Options Help — ]
JRIOL

1.9 Add aggregation functions
In bQuery-Tool, we can define a group by field using functions such as: sum, avg, min,
max and count.

To create a new formula and add it to a query:

1) On menu click: Data -> Aggregation Fields

- saaTQEe_ry-Tool 30550 - ‘

F

- Agg

FieldName  [aa01

Function |sum | Onfield [cds1s041.0qua » Foreach

- Layout
Textbefore field |Total Quantity
Text after field |

Data Type ILong vI Format |002 »  1234.00

Offset result Left v | Distance Io
- Opti

¥ Include field in result

Form fields:
a. Field name — Name of function field. Default is generated by BQT.

b. Function — Choose functions such (sum, avg, min, max and count) to be calculated

on the chosen field.
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On Field — Choose the field which will be calculated by the function.

For each — You can choose the field on which you want to group by.

Text Before field — You can define the text description before the value of the
function field in the report. Additional sort fields values can be add as variables :
SORT1, SORT2, SORT3, SORT4

Text After field — You can define the text description after the value of the function
field in the report. Sample expression of 1234.00 (or 1234,00) is displayed to ease
the choice of the format.

Data Type — Data type can be determined. Options are: long, double and string.

Format — Function field result data format. You can chose from a list of formats that
are supported in your Baan system. Sample expression of 1234.00 (or 1234,00) is
displayed to ease the choice of the format.

=
mim BaanQ 3.0 [550] - Select Format | = = P
001: 1234.00 -
002: 1234.00
003: 1234.00 =
004: 1234.0000
005: 1234.00
006: 1234.00
007: 1234.0000 i
008: 1234.00
009: 1234.000000
010: 1234.00
020: 1234.0000 II
021: 1234.00
095: 1,234.00
096: 1,234.00
400:
710: $ I
ron. = o
Ok Cancel
.~ vy

Offset result — define the position of the result field by setting the offset (Left or Right)
and the

Distance - distance of the offset in characters.
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2 Add conditional field

In bQuery-Tool, we can define a conditional field and Columns can get a certain value based on

results of the logical condition.

To create a new formula and add it to a query:
1) On menu click: Field -> Conditional Field

[ -
wam BQT 3.0 [550] - Conditional Field

- Layout

FieldName  [cc2

Description  [Conditional Field - 8

- IF function

Logical Condition[ciitmool.dsca b |= v| Mac - Holand »
Value if true 'Mac - Holand »

Value if false I

»

- Settings

Data Type m
Columnwidth [0

- Options

OK

[V Include fieldinform [V Include field in result

Cancel

Form fields:

a.

Field name — Name of the conditional field. Default is generated by BQT.

Description — Description of the conditional field.

Logical Condition - You can choose the field where you want to have the condition
applied on it using the operators: =, <>, >, <, >=, <=

Value if true — You can define the value in the result in case the condition result is

true.

Value if false — You can define the value in the result in case the condition result is

false.

Data Type — Data type can be determined. Options are: long, double and string.

Column Width - Define the width for the conditional field to override the default.
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3 Customizing the Query form

When Printing Query results, we acquire this window where we can specify the ranges of
each field:

S
asm Baan Query Tool 3.0 [550] - Print Item with Text o8] %

From To

item [ v - [zzzzzzzzzzzzizz » Continue
ftem Type [Purchased ~| - [subcontracting ~l Cancel
Description | - Save Defauts |
Material Costs | .9999 = | .9993 Qear Defaults

Sales Order 10 i CEEEEE]

3.1 Hiding Fields from Query

All query fields are automatically populated to the form. We may decide to hide some
fields or show them. This is done by field settings -> uncheck “Include field in form”

- Options
[ Include field inform [V Inclu

Zoomto Ii) '

If all the fields in the query have this option unchecked, we will not have a form at all.

If we have a form with few fields, but wish to hide it for a special reason (run in job for
example), we can hide it by going to the menu: Options -> Device and check “Hide Print
Form”. Once we uncheck this option, the form will return as it was before.

3.2 Save Defaults in the Form

If you made some changes to a form and want them to be saved for further use, click on
“Save Defaults” button. Every time we print this query, the form will receive the same
values we have saved. We may decide to “hide” the fields we have added values to. This
is a way to give hard coded constrains on the query.

Page 22 of 34



bQuery-Tool 3.0
User Guide

NAZDAQ - Nazareth Data Quest

3.3 Zoom into a Session

For fields that are related to tables, we can specify a zoom session, in order to better
browse the table for a list of values available for this field

For example:

If the Item is one of our form fields, we can specify to zoom to session tiitm0502s000.
Inserting a Zoom session is done manually or by zooming to the session Display Sessions.
It is recommended you find the zooming session in a standard Baan session and copy

the code number.

.
=sm Baan Query Tool 3.0 [200] - Field Settings

o|®@] %

- Layout

tdslis041.item - item
Domain: tcitem - Type: String

Column description [Item

Column width 0
Column alignment  |Default ¥ '
Column format »

- Opti

[V Include field in form [V Include field in result
Zoomto |[ciitm05023000 ) Display ltemList

ok | cancel

When printing this query, we get a zoom icon next to Item field

r WD ————
mim Baan Query Tool 3.0 [550] - Print Item with Text

=G X

Item
ltem Type

Description

Sales Order

Material Costs |—999999999999999. 9999

From To

- |2z2ZzzZzzZzzzzZiz >
Purchased 2 -

Subcontracting v

I = IZZZZZZZZZZZZZZZZZZZZZZ:

& I999999999999999.9999

Jo S CEEEET

Continue I

[
Save Defaults
Clear Defaults
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Using this we are able to browse for giving a better range constrain on our query

File Edit Group Workflow Options Order Tools Special Help

B2B-SRV-PRD-P
B2B-SRV-PRD-S
B2B-SRV-TST-P
B2B-SRV-TST-S
B2E-MRG-PRD-P
B2E-MRG-PRD-S
B2E-MRG-PRD-W
B2E-MRG-TST-P

Baan2Baan

Baan2Baan Production - Ser
Baan2Baan (Test)
Baan2Baan Test - Service
Baan Mail-Merge

Baan Mail-Merge (Service)
Baan Mail-Merge WebTop Edi
Baan Mail-Merge (Test)

Material

EI|E|§| “’l:ﬁ:lln‘?ﬂl M|I4|4 » |)|| )Nll«l«l»l»ll le?l
«|» i:

[l fol]

Size

'Select’

and 'zoom' for item details
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4 Filtering output

You can the output results using operators such as: Equal, Not Equal, Greater, Greater/Equal,
Less, Less/Equal, Like and Not Like.

To do this on menu click: Data -> filter, a window like this appears

' BQT 3.0 [90] Filter

=@ %

tcibd001.citg

+
2
3,
4
S.
[
7.
8.
9,

10.

UL

Cancel

|

This option is available to the programmer of the report and can’t be changed during run-time.

When several filter conditions are defined they will all be applied together (and).

5 Sorting output

You can sort the output results by specific fields.
To do this on menu click: Data -> Sort, a window like this appears

r — —
BaanQ 3.0 [90] - Sort S (@] R ]
Sort by:
tcibd001.item »  ©@ Ascending
(©) Descending
tcibd001.wght »  © Ascending
(©) Descending
»  © Ascending
() Descending
[—> © Ascending
(©) Descending
[ ok ] [[cancel ]
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You can zoom for what field you want to sort by:

wiim BaanQ 3.0 [550] - Select Field (ol®] = ]

>

tdslsO4l.item - Item
tdsls041.odat - Order Date
tdsls041.cuno - Customer
tccom010.nama - Customer Name
tdsls041l.orno - Sales Order
tcmes010.dsca - Country
tdslsO4l.amta - Amount —
tdsls040.ccur - Currency S

Ascending and descending sorting are available.

Note: You can’t sort according to a formula field
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6 Customizing Query Layout

The appearance of every field in the query report can be customized for better
presentation.

In order to customize a certain field appearance, double click on the field on the left pane,
and a window similar to this will appear

m Y

=um Baan Query Tool 3.0 [550] - Field Settings = E XS

tdslis040.ccur - Currency

Domain: tcccur - Type: String

- Layout

Column description  [currency

Column width 0
Column alignment  |Default v
Column format »

- Options

[V Include fieldinform [V Include field in result
Zoomto »

oK | Cancel

|\ ——— y,

The following options are available.
- Rename Column Description to a new description

- Specify a specific size for column width to appear in output (to override default that
may be too big)

- Change column alignment in output results (including column data and column title).
The following options are available:
Default — Field default from Baan/ERP Ln
Center, Right, Left

- Specify the format of the field as it will be displayed in the result. The formats
available are the ones defined in the system.

Include field in results
If this option is checked the field will appear in output result (Default is Yes for all fields).
In order to hide a field from the output, uncheck it.
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7 Output Options

For automating the process of generating queries, you can save your default print device
and the output file for each query (the parameter that is passed to the device). This is
particularly useful in jobs.

1) In bQuery-Tool click on menu: Output -> Device
2) You will acquire this window

7.1

r N\

sim Baan Query Tool 3.0 [550] Print Options o |8 X
Device Name: [BZI\'IH'/‘Z 4
Output File: |-'cype Excel

Device Type: (¢ Standard " Wide

Ok Cancel

When printing, the query will automatically be sent to the device (B2Win in Excel format
in this case) and the user won’t be prompted to enter the device name. If the Print form
is also hidden (Hide Print Form), pressing on the query will result in producing an Excel
Sheet with no questions being asked on ranges and print devices.

Wide Reports

Standard Baan devices have a limitation of 300 characters in width. To bypass this
limitation, and in order to make queries with unlimited number of characters in the
width, “Wide” queries can be defined.

Wide reports need to go to a Baan device that supports more than 300 characters.
Printing Wide reports to standard devices (Like “D” or Printers) will not produce the
desired results.

The following are a sample of two Print devices that support wide reports:

ASCIF — Writing to an ASCII file on the Baan server (Standard device)
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B2Win — With B2Win (Add-on from NAZDAQ), you can print your wide query output into
Excel — Use B2Win 6.6 or higher

8 Organizing Queries

Queries are organized in the order they have been created. In order to change the order of
your queries, you may wish to use the Query Organizer. This is useful in Run-Only Query
Mode (covered in the next chapter)

To organize your queries, on menu click: Query -> Organize

e BaanQ 3.0 [550] - Org... = | & | &

~

naz-sales -
pecial items

Item with Text

inventory valuation

My new Query

Ehab-Analysis

naz-sales - EXCEL

Maintenance customers

Outer Example

sales order

wide

Mosaic User Group Query

long query

Customers Status

Ehab-BigCustomers AL

8 o Down Close

m

From this window you can change the order of your queries by selecting a query and

clicking on Up or Down.
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9 Run-only Query

Administrators and Key Users can create queries. Regular users should not be able to
change queries, but only run them and use the results. For regular users, a run-only query
session is available - tccom2bqt3p

Usage:

Open session: tccom2bqt3p

9.1

List of
queries for
user bsp

Copy Query

View users

File Hel ;
i Print Query

Users List: bsp v

>

naz-sales - Print Query j

special items Copy Query — Copy Query
Item with Text ——] L

inventory valuation Exit

>|[My new Query

Ehab-Analysis

naz-sales - EXCEL
Maintenance customers
Outer Example

sales order

wide

Mosaic User Group Query
long query

Customers Status
Ehab-BigCustomers

<

m

In the run-only session you can copy queries made by other users. You have no permission to
change them, but can copy them to your local environment.
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10 Automating Queries

10.1 Run Query inside Baan Run Program

After you have created a query you can run it automatically without opening the bQuery-
Tool interface. You can do that by giving the query number as an argument to bQuery-Tool -
Run only session as in the following:

mam ttdsk2080m000 : Run Program [550]

Program/Session |cccom2ch3p
Program Argument [89000000000037
Run External Program I

Cancel

Help

You can acquire the Query number from bQuery-Tool session:

mum Baan Query Tool 3.0 [550]

File Query Field Data Qutput Help

Queries for user bsp:

odat
cuno
nama
orno
dsca
amta
ccur
rats
uamt
ccll
ccl2

[naz-sales

=

Order Date
Customer
Customer Name
Sales Order
Country
Amount
Currency

Rate

Amount in USD
big or small
Conditional Field - 12

lOuery code: BQO00000000037 l

lEowni| tPER]

Table Ed:lsou » Sales Order Lines

Search |

orno Sales Order -
lpono Position Number B
cuno Customer 2
drct Direct Delivery L3
item Item

cntr Container

opol Item Category

cpva Product Variant

sdsc Standard Description

pric Price

stpr Structure Price

plev Price Level

cups Sales Price Unit

cvps Conversion Factor Price to Inve
citg Item Group -~

If you wish to automate a query that is written by a different user, the query owner user
name should be passed in parameter as in the following example:
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s tdisk2080m000 : Run Program [550] =
Program/Session [tccom2bgrap
Program Argument [BQ000000000037,bsp OK
Cancel
Run External Program u Help

Queries can be added to the Baan menu as in the following (Need Baan Tools knowledge)

ttadv3161s000 : Maintain Menu
File Edit Group Workflow Options Order Tools Special Help

ala|a| o|&|s|R| @l <> ] i «|mr| T[]

Menu Field Type |Session L]
Ses/Men/Pr/Quer Eccomqut:s » I_

. Link Descr. v |
Label lBun Query Tool v3.0
Process Info IBQ000000000037,bsp
Selection Code [T Bold r
Form Position IO_ Reverse I
Color fmice ~[pinking r
Active v Underlined r

U
alphanum

10.2 Run Query From Command-Line

Queries can be run from a command line. Here is an example:

call "C:\Program Files\Infor\BW\Baan IV\bin\bw.exe" "Samra.bwc" tccom2bqt3p

BQ000000000037,bsp
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10.3 Run Query From BECS

You can create shortcut to your query inside BECS

To do this:

1) Open BECS

2) Click on Menu: File -> New to create a new configuration

3) Insert Hostname, user, ... (According to your system)

4) In command field insert: tccom2bqt3p <Query code>,<user> (Where Querycode is
the query you want to run from this shortcut, and user is the user id that created the
query )

e BW C fion - C: bwe SRS
»w::g:]ms | Font | Automation | .
Hostame: 102010 e |
Connect As: I~ Curent User | _ s |
| I —— P
I ™ Save Password
Metrod [ a—
I Portpumber: = | RUN!
| ==
BSE: [baantcbse
Bshe name: fopat
Cormand: o7 BQOCOOGHO000E Tbop

5) Click on save as and you will have a new shortcut inside BECS, named queryTest as

we specified for example

[@ BECS - Infor BW Environment and Configuration Selector 90 W T il iy e e o
g

File View Run Tools Help

Dy me|X|R|! P

Filename Environment Path BWVersion  BaanService  Hostname Bse Domain Username
dcbwe Baan IV C:\Program Files\Infor\BW\Baan IV B40c94 4c e\baandc baan
queryTest.bwc Baan IV C:\Program Files\Infor\BW\Baan IV B40c94 104010 /baandc/bse aziz
samra.bwe Baan IV C:\Program Files\Infor\BW\Baan IV B40c.94 104010 /baandc/bse aziz
Rain.bwc ERPLN C:\Program Files\Infor\BWA\ERPLN  8.42.02.9 10.4.023 fAIn6.1 baan

6) Launch queryTest will print the query in the device you chosen
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Warning

Trade Marks
bQuery-Tool is a trade Mark of NAZDAQ Ltd.

All other referenced company and product names may be trademarks or registered trademarks
of others.

NAZDAQ

For Support, please contact info@nazdag-it.com
Phone +972-4-608-0023

Fax +972-4-647-0112

Our office Hours are Monday - Thursday 10:00 — 19:00 and Friday 10:00 — 17:00
GMT +2

Check our website for other Baan and ERP Ln Related Products

www.nazdag-it.com

June 2012
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