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1 Introduction 
 

There is a new and elegant way to create queries and ad-hoc reports on your Baan data: 

bQuery-Tool. This Baan session comes with an easy to use graphical interface which allows 

you to create dynamic queries from your Baan database. 

 

 

 

 
  

Add a field to 

query 

Use to quickly find your 

table 

Change fields order 

Remove field 

from query 

Chose a table 
Pick a Query 

Query Selected Fields 

Print Query 
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2 Make a Query 

 

2.1 Create a new Query 

 
In bQuery-Tool you can create a query that display a table, with the field you want, from 

one or more tables in the database. 

 

To create a Query in bQuery-Tool: 

 

1) You need to open bQuery-Tool session, If you don’t know how ask your administrator 

 

2) The following  screen will be displayed: 

 
To start working in a new Query click on menu bar: Query -> New and insert a query name 

 

3) Now you have a new query with a new name 

 

4) You can view all your queries from this drop down control under Queries for user<username> 
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2.2 Delete Query 

 
You can delete the query you created by loading the query and click on menu: Query -> 

Delete 

 

2.3 Rename a Query 

 
You can rename the query you created already by loading the query and clicking on 

menu: Query -> Rename, insert a new name and click ok 

 

2.4 Add Fields to Query 

 
Now after you have created a new query, you are ready to add fields to it. 

 

To add fields to query: 

 

1) Choose the table 

   
 

Find icon to quickly find 

your table 
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If you have the table name insert it on the table field, if not click on find icon and a selection 

window appears: 

 

 

“Display All Tables” will go to the standard Baan session “Display Tables” 

 

“Display Tables by Description” will open a new window that will allow searching for the 

table by description and table code 

 

“Display Current Query Tables” will display only the tables that are used in the current 

query. 

 

For example if we click on Display Tables by Description, a window like this appears, in 

Search field we insert “Sales order” 

 
Select a table from the list and click Ok 

 

2) Add fields  

 

Add the fields you want from the table, by selecting the field and click the add button 

(marked in red) 
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You can also find fields without knowing the 4 letter code. You can simply search for 

a certain field using the “Search” that performs a search on both the field name and 

field description. 

 

As an example, if we want to add the Delivery Date for a sales order line but are not 

sure of the name of the field, we can simply search for “Date” as below and the only 

fields that contain “Date” in their names will appear, making our life easier in 

choosing a field. 
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Printing a simple Query 

 
Queries created can be printed to Baan devices. The following is an example of printed a 

simple query. 

 

 

1) To Print a Query, press “Print Result”  

 

 
 

2) A windows like this appears (Query Form) 
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3) Click Continue button and you get the option to choose a device 

 

4) After we specify the device, query results will be printed (Query Report Output).  

 
The Query Form and the Query Report output can be customized to enable greater 

possibilities and flexibility as we can see in the following chapters.  
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Add Enumeration, Text and Array Fields 

bQuery-Tool supports working with Enumerated fields and Text fields and array fields, 

unlike non-Baan query and reporting tools that do not recognize these fields. 

 

As an example, if you add field tiitm001.kitm (Item Type) to your query, bQuery-Tool 

recognizes this as an enumerated field. In the Form, you will be able to choose between 

Manufactured, Purchased and so on. In the report output, these values will appear 

instead of the number (between 1 and 6). 

 
If we choose a field that is a Text field, the text that is associated will be printed in the 

query report (and not the “text number”). 
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You can also chose a field that is an array and bQuery-Tool will let you print a specific 

range of each value of the array 

 
Array will also be visible in output results 
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2.5 Add Fields from a second Table (Table Linker) 

 
In the same query you can add fields from more than one table, and link these tables 

together using a common field that you can select whenever a field from another table 

is added. 

 

After you added fields from the first table to your query, you can add fields from 

another table by these steps: 

 

1) Find the second table that you wish to have fields from it 

2) After you have the table selected, add fields to query and a window will be opened 

 
3) Specify a field from both tables that is common for both of them to establish the link using 

it. You can browse tables already linked in this query, and browse field inside the selected 

table 

 
                 Tables browse 

4) After this you can add any field from this second table 

 

Note: You can repeat this by adding a third or more tables to query 

Table already added 

before Table you want to 

link 
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To view or maintain a link between two tables in the query: 

 

On menu click: Query -> Table Linker 

 
The possible actions for each link are the following: 

 

- Add Link – add another link to query (same as we did above) 

- Link Type – Change an already existing link with 3 link types available: 

 
- Remove Link – we can remove already exists link from this query 

 
Example: 

 

We want to create a query that displays Sales Orders lines with customer name and 

Item description with price and quantity for each line 

 

In order to display all this information we need to link 3 tables together: 

- tdsls401 – That contains Sales order Lines. 

- tcibd001 – we link this table to get item description 



bQuery-Tool 3.0 

User Guide 

NAZDAQ – Nazareth Data Quest 

 

Page 14 of 33 

 

Here is an example of the query in bQuery-Tool (To view field details on menu click: View -> 

View Fields Details): 

 
Print Results for this query: 
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2.6 Add Calc. fields 

 
In bQuery-Tool, we can define formulas that calculate a result from table fields and 

other formulas. 

 

To create a new formula and add it to a query: 

 

1) On menu click: Field -> Add Calc Field 

 
Form fields: 

a. Column name – name of formula field. Default is generated by BQT. 

 

b. Column Description – Description of column, as it will be displayed in the report. 

 

c. Column Type – Data Type of the formula field: Possible values are Date, Long, 

Double 

 

d. Column Width – specify the column width as it will be displayed in the report. 

 

e. Column alignment – formula alignment in report. Options are: Default, Center, 

Right and Left 
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f. Column format – formula format. You can chose from a list of formats that are 

supported in your Baan system. Sample expression of 1234.00 (or 1234,00) is 

displayed to ease the choice of the format. 

 

 

2) Specify the formula 

 

Formulas may include 2, 3 or 4 fields. 

 

<Field1> <Operator> <Field2> 

 

Or 

 

(<Field1> <Operator> <Field2>) 

<Operator> 

(<Field3> <Operator><Field4>)  

 

Operators supported are +, -, *, / 

 

 

Example of a formula: 

 

We want to display all the sales order lines amount in database, with their items and 

price.  

 

The formula is (Item price * ordered quantity) 
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Table we will use is tcibd001.The Query is the following: 

 
Formula named: Amount /Item 

 
Now output results will be like this: 
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2.7 Add aggregation functions 
In bQuery-Tool, we can define a group by field using functions such as: sum, avg, min, 

max and count.  

To create a new formula and add it to a query: 

 

1) On menu click: Field -> Function Field 

 
Form fields: 

a. Field name – Name of function field. Default is generated by BQT. 

 

b. Function – Choose functions such (sum, avg, min, max and count) to be calculated 

on the chosen field. 

 

c. On Field – Choose the field which will be calculated by the function.  

 

d. For each – You can choose the field on which you want to group by. 

 

e. Text Before field – You can define the text description before the value of the 

function field in the report. Additional sort fields values can be add as variables : 

SORT1, SORT2, SORT3, SORT4 
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f. Text After field – You can define the text description after the value of the function 

field in the report.  Sample expression of 1234.00 (or 1234,00) is displayed to ease 

the choice of the format. 

g. Data Type – Data type can be determined. Options are: long, double and string. 

 

h. Format – Function field result data format. You can chose from a list of formats that 

are supported in your Baan system. Sample expression of 1234.00 (or 1234,00) is 

displayed to ease the choice of the format. 

 

 

i. Offset result – define the position of the result field by setting the offset (Left or Right) 

and the  

 

j. Distance - distance of the offset in characters. 
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2.8 Add conditional field 
In bQuery-Tool, we can define a conditional field and Columns can get a certain value based 

on results of the logical condition. 

       To create a new formula and add it to a query: 

1) On menu click: Field -> Conditional Field 

 
Form fields: 

a. Field name – Name of the conditional field. Default is generated by BQT. 

 

b. Description – Description of the conditional field. 

 

c. Logical Condition - You can choose the field where you want to have the condition 

applied on it using the operators: =, <>, > , < , >=, <=  

 

d. Value if true – You can define the value in the result in case the condition result is 

true. 

 

e. Value if false – You can define the value in the result in case the condition result is 

false. 

 

f. Data Type – Data type can be determined. Options are: long, double and string. 

 

g. Column Width - Define the width for the conditional field to override the default. 
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3 Customizing the Query form 

 
When Printing Query results, we acquire this window where we can specify the ranges of 

each field:  

 
3.1 Hiding Fields from Query 

 
All query fields are automatically populated to the form. We may decide to hide some 

fields or show them. This is done by field settings -> uncheck “Include field in form” 

 
If all the fields in the query have this option unchecked, we will not have a form at all. 

 

If we have a form with few fields, but wish to hide it for a special reason (run in job for 

example), we can hide it by going to the menu: Options -> Device and check “Hide Print 

Form”. Once we uncheck this option, the form will return as it was before. 

 

3.2 Save Defaults in the Form 

 
If you made some changes to a form and want them to be saved for further use, click on 

“Save Defaults” button. Every time we print this query, the form will receive the same 

values we have saved. We may decide to “hide” the fields we have added values to. This 

is a way to give hard coded constrains on the query. 
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3.3 Zoom into a Session 

 
For fields that are related to tables, we can specify a zoom session, in order to better 

browse the table for a list of values available for this field 

 

For example: 

 

If the Item is one of our form fields, we can specify to zoom to session tcibd0501m000. 

Inserting a Zoom session is done manually or by zooming to the session Display Sessions. 

It is recommended you find the zooming session in a standard Baan session and copy 

the code number.  

 

  
 

When printing this query, we get a zoom icon next to Item field 
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Using this we are able to browse for giving a better range constrain on our query 
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4 Filtering output 
You can the output results using operators such as: Equal, Not Equal, Greater, Greater/Equal, 

Less, Less/Equal, Like and Not Like.  

 

To do this on menu click: Data -> filter, a window like this appears 

 
 

This option is available to the programmer of the report and can’t be changed during run-time. 

When several filter conditions are defined they will all be applied together (and). 

 

5 Sorting output 
You can sort the output results by specific fields. 

 

To do this on menu click: Options -> Sort, a window like this appears 

 



bQuery-Tool 3.0 

User Guide 

NAZDAQ – Nazareth Data Quest 

 

Page 25 of 33 

 

 

You can zoom for what field you want to sort by: 

 
Ascending and descending sorting are available.  

 

Note: You can’t sort according to a formula field 
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6 Customizing Query Layout 

 
The appearance of every field in the query report can be customized for better 

presentation.  

 

In order to customize a certain field appearance, double click on the field on the left pane, 

and a window similar to this will appear 

 
The following options are available.  

 

- Rename Column Description to a new description 

 

- Specify a specific size for column width to appear in output (to override default that 

may be too big) 

 

- Change column alignment in output results (including column data and column title). 

The following options are available:  

Default – Field default from Baan/ERP Ln 

Center, Right, Left 

- Specify the format of the field as it will be displayed in the result.  The formats 

available are the ones defined in the system.  

 
Include field in results 

If this option is checked the field will appear in output result (Default is Yes for all fields). 

In order to hide a field from the output, uncheck it. 
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7 Output Options 

 
For automating the process of generating queries, you can save your default print device 

and the output file for each query (the parameter that is passed to the device). This is 

particularly useful in jobs. 
 

1) In bQuery-Tool click on menu: Options -> Device 

2) You will acquire this window 

 
When printing, the query will automatically be sent to the device (B2Win in Excel format 

in this case) and the user won’t be prompted to enter the device name. If the Print form 

is also hidden (Hide Print Form), pressing on the query will result in producing an Excel 

Sheet with no questions being asked on ranges and print devices. 

 

7.1 Wide Reports 

 
Standard Baan devices have a limitation of 300 characters in width. To bypass this 

limitation, and in order to make queries with unlimited number of characters in the 

width, “Wide” queries can be defined. 

 

Wide reports need to go to a Baan device that supports more than 300 characters. 

Printing Wide reports to standard devices (Like “D” or Printers) will not produce the 

desired results. 

 

The following are a sample of two Print devices that support wide reports: 

 

ASCIF – Writing to an ASCII file on the Baan server (Standard device) 

 

B2Win – With B2Win (Add-on from NAZDAQ), you can print your wide query output into 

Excel – Use B2Win 6.6 or higher 
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8 Organizing Queries 
 

Queries are organized in the order they have been created. In order to change the order of 

your queries, you may wish to use the Query Organizer. This is useful in Run-Only Query 

Mode (covered in the next chapter) 

 

To organize your queries, on menu click: Query -> Organizer  

 
From this window you can change the order of your queries by selecting a query and 

clicking on Up or Down. 
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9 Run-only Query 
 

Administrators and Key Users can create queries. Regular users should not be able to 

change queries, but only run them and use the results. For regular users, a run-only query 

session is available - tccom2bqt28p  

 

Usage: 

 

Open session: tccom2bqt28p 

 

  

 

  

Print Query 

View users 

list 

List of 

queries for 

user bsp 
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10 Automating Queries 
 

10.1 Run Query inside Baan Run Program 

 
After you have created a query you can run it automatically without opening the bQuery-

Tool interface. You can do that by giving the query number as an argument to bQuery-Tool – 

Run only session as in the following:  

 
You can acquire the Query number from bQuery-Tool session: 

  
If you wish to automate a query that is written by a different user, the query owner user 

name should be passed in parameter as in the following example: 
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Queries can be added to the Baan menu as in the following (Need Baan Tools knowledge)  

 
 

10.2 Run Query From Command-Line 

 
Queries can be run from a command line. Here is an example: 

 
call "C:\Program Files\Infor\BW\Baan IV\bin\bw.exe" "Samra.bwc" tccom2bqt3p 

BQ000000000037,bsp 
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10.3 Run Query From BECS 

 
You can create shortcut to your query inside BECS 

To do this: 

 

1) Open BECS 

2) Click on Menu: File -> New to create a new configuration 

3) Insert Hostname, user, … (According to your system) 

4) In command field insert: tccom2bqt3p <Query code>,<user> (Where Querycode is 

the query you want to run from this shortcut, and user is the user id that created the 

query ) 

 
5) Click on save as and you will have a new shortcut inside BECS, named queryTest as 

we specified for example 

 
6) Launch queryTest will print the query in the device you chosen 
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Warning  

 

Trade Marks 
 

bQuery-Tool is a trade Mark of NAZDAQ Ltd. 

 

All other referenced company and product names may be trademarks or registered trademarks 

of others. 

 

NAZDAQ 
For Support, please contact info@nazdaq-it.com 

 

Phone  +972-4-608-0023 

Fax  +972-4-647-0112 

 

Our office Hours are Monday - Thursday 10:00 – 19:00 and Friday 10:00 – 17:00 

GMT +2 

 

Check our website for other Baan and ERP LN Related Products     

  

www.nazdaq-it.com 

 

July 2012 
 


