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1 Introduction 
 

One of the most powerful features of B2Win is that it does not only take data from Baan/ERP Ln and 
transfer it to different file formats, but it helps “translate” the output from “made to be printed” format 
to logical “tables” – with one header line only and different columns with well defined data types (most 
common application is Excel). In the following manual we will discuss the different methods used in 
B2Win in order to allow easy conversion of reports to table format. 
 
Most reports in Baan and ERP Ln can automatically be transferred to table format with no additional 
human intervention needed. For some reports, additional information needs to be given to B2Win in 
order to allow better conversion into tabular mode.  If you have a sub-headers along your report, or a 
strange header, or a different delimiter than the standard “|” (Pipe) in Baan/ERP Ln reports, it is 
suggested to use the “Customize” option in order to allow better report conversion. Every report can 
have a different customization per language. Once these customizations are built on a sample data 
report, they can be used every time this same report is run to the B2Win device – streamlining the 
generation of meaningful table format reports. 
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1.1 Report Types 
 
We categorize three main report types in Baan and ERP Ln, when it comes to converting using B2Win. 
First, “Standard reports” that have a clear header, aligned detail lines and a common delimiter, which 
can be automatically imported to table format with B2Win. From the other hand, “Non-standard 
reports” miss one of the characteristics of Standard reports, and may include sub-headers and sub-totals 
in the report. Non-Standard reports need to be customized in order to be converted to tabular mode. 
The third type of reports is “Transpose reports”, which have titles on every line and the data in front of 
the title line. These reports need customization and must be “transposed” in order to convert them 
properly to table format. 

 
1.1.1 Tabular – Standard 

 
The following is the definition of Standard Baan/ERP Ln Reports that can automatically be imported to table 
format using B2Win smart automatic engine – without the need of the B2Win Report Customizer (RBC). 
 
An example of Standard report: 

 
A report is a Standard Baan/ERP Ln Report when the following conditions are fulfilled: 
 

1. The report delimiter is pipe and it appears in the header lines as well as in the detail lines 
 

2. There are two lines of dashes; one before the main header and one after it 
 

3. The main header (as defined here) appears in every page, exactly in the same lines 
 

4. The main header does not contain more than 3 lines (excluding the two dash lines)  
 
5. Columns in report must be aligned, you can see this by looking at the delimiter if it’s all the way on the same 

position, and makes a horizontal line 
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1.1.2 Tabular – Non-Standard 
 
A report is “Non-standard” if any of the five characteristics of “Standard” reports is not fulfilled. This is also the 
case when report contains additional data, like another sub-header above the main header, lines inside the 
tabular data, like sub-headers, totals and subtotals – or when the main header appears in different positions in 
every page.  
 
In the following example there is more than one reason this report is not standard. 

 
1) Having an extra line above main header 
2) Order number inside table 
3) Total Order line and Total on order makes it non-standard 

 
 

Non Standard reports can be converted to table format, after customizing the output in the BRC.   

Main Header 
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1.1.3 Transpose 
 
In this report data is represented in rows. A header in the first few lines includes few key fields and the report 
is organized in such a way that the field name is written in every line, next to the value of that field. There 
could be up to 3-4 columns in every report with the same pattern. 
 
Example:   

 

 
 

Transpose Reports can be converted to table format, after customizing the output in the BRC. 
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1.2 Report Parts 
 
A report according to BRC can be separated into 4 parts: Title, Main Header, Details and 
Floating Header. 
 
In the next chapters we will explain in more detail the different parts and how to handle 
each one for better customization of the report. 
 

 

 
 

  

Title 

Header 

Details 

Floating 
Header 
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2 Titles 
 

2.1 Introduction 
 
Titles are usually on every page and contain all lines from the start of the first page until the 
main header’s first line. In many cases, the BRC can recognize the title and automatically 
remove it from the resulting table. 

 
2.2 Keep Text before Header 

 
The title is usually removed from the table result but can be kept if otherwise indicated 
by the BRC. To keep the title in the resulting data, you can enable “Keep Text before 
Header” 

 
Example: 
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In BRC menu we click on Options and enable Keep Text before Header  
 

 
2.3 First Page with a Cover Sheet 

 

Sometimes, the title appears in the first page only (Cover Sheets) and is not repeated in the 
same way in pages 2 and more. This can be defined in BRC. 
 
The following is an example: 

 
A standard report with a cover sheet in the first page 

We may choose to delete this text or keep it. By default, BRC will delete it and only detect the columns 
that contain data. 
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3 Main Header 
 

3.1 Introduction 
 
Every report has a header that contains the column names which usually appears in every page. BRC 
looks for the header and places it once in the resulting table. 
 
Baan uses a default delimiter between columns with the default being the “|” (Pipe) 
BRC by default looks for this delimiter. With RBC, you can define a different delimiter. 
 
In this chapter we will go over the four kinds of headers that BRC can handle, and give an example of 
each one of them. 

 
3.2 Header Types 

 
3.2.1 Standard Header 

 
A report contains a standard Baan header that comes always in the same position in each page of the 
report. 
 
Example:

 
When customizing a similar report to this, BRC will usually auto detects the Main header and marks it 
in blue. 
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How BRC works: 
 
BRC searches for the first dotted line in the first page and marks it as Main Header for this report. In 
some cases the first dotted line is not the start of the header and therefore BRC will wrongly detect it 
as the main header. In this case, we should specify the Main Header manually. 
 

 
3.2.2 No Header 

 
Some reports have data with no header. These are usually customized reports.  
 
Example: 

 



B2Win 7 

Implementation Guide 

NAZDAQ – Nazareth Data Quest Ltd. 

 

Page 14 of 42 
 

If a report is defined as a “no header” report, BRC will automatically detect the columns

 
BRC auto detected the columns in step 2 

As the report has no header, no columns names exist. We may want to insert column names. 
 
1) Right Mouse Click on the empty Column Name and click on Rename 
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2) Specify a column name 

 

Do the same scenario for the rest of the columns as you chose, to have an organized tabular report 

 

3.2.3 Header in First Page only 
 
If we have a header in the first page only, while other pages contain data with no header, we need to 
specify this option in BRC: 

 

 
Example of a report that is set to have Header in first page only 
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3.2.4 Header in Different Positions 
 
Sometimes, the header does not appear in the same location in every page, as in the following 
example: 
 
In the first page 

 
In Second Page and after: 

 
We need to specify this option to BRC to detect the headers and data inside it 
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3.3 Usage 
 

3.3.1 Assign Main Header 
 
If the main header is not detected automatically, or if it was mistakenly detected, we can manually 
specify the Main Header using RBC. 
 
To set main header: 
 
1) Go to BRC step 1 
2) Mark the header text you want to chose 
3) Right Mouse Click on the text and click on: Header -> Assign Main Header (marked text will be 

colored in Blue color) 

 
4) To specify what kind of header is that (Standard Baan header, Header in first page only, Header 

in different position) (See Header Types help Page)  

 
3.3.2 Remove 

 
You can remove Main Header that you already set: 

 
We assume that there is a Main header set, Click on Menu Item: Edit -> Header -> Remove main 
header. 
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4 Detail Lines 
 

4.1 Introduction 
 
Detail lines are mainly handled in BRC step 2, after we have worked on the title, header 
and floating headers in Step 1.  The delimiter is automatically assigned as “|” (Pipe) 
unless defined differently in Step 1. After the detail lines are generated, different 
options and special cases for the detail lines can be picked as described in this chapter. 
 

 
Figure 1 – Step 1 

 
Figure 2 –Step 2 - Detail lines 
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4.2 Remove empty lines 
 
By default, empty lines are kept in the resulting table. Using BRC, you can specify an 
option to force deletion of empty lines from report. 

 
4.3 Remove delimiter only lines 

 
By default, empty lines that have the delimiters only (no data) are kept in the resulting 
table. Using BRC, you can specify an option to delete such lines from report. 

 
4.4 Delete columns - Undeleted columns 

 
You can delete any column from the report in BRC step 2. To do this, Right mouse click 
on the column and click on Delete. 
 
To view the deleted columns: on the menu click on Options -> Show Deleted columns. 
 
Note: You can’t delete columns that are generated from Floating Headers. 

 
4.5 Data Types 

 
Data Types are guessed by B2Win or using the Global Data Dictionary (Review B2Win – 
Implementation Guide for more information about Data Dictionary session tccom2dd7). 
Many times, this is not enough as some columns can have confusing data types. To 
avoid this, for each column in the report, use BRC step 2 in order to specify an explicit 
Data Type in order to display it in Excel output. 
 
Note: We can’t set a data types from BRC step 2 for Floating Header Columns. This can 
be done in step 1 - left pane 
 
To Set Data Type for a specific column: 
 

1) Right Mouse Click on a column, and select Data Type 
2) Select the Data Type of the value in this column 
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After we finish this, the title of this column will be colored in Green instead of Blue – 
which means the data type for this column is now set. In this case BRC won’t try to 
guess what type this column is. 

 
 

4.6 Split – With or Without cut 
 
Some reports don’t have delimiter between columns or have spaces between columns. 
B2Win cannot split these columns automatically, so user must edit this manually using 
RBC Step 2. 
 
There are two ways of Splitting: 
 

1) Standard Split – Split a column into two columns, without removing any data 
from the columns 
 

2) Split with Cut – Splits two columns while removing the delimiter character 
(wherever the split bar was clicked) 

 
To Split a column to two derived columns: 
 

1) Right Mouse Click on the column, and select: Split -> Standard Split 
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2) If you pass the mouse cursor on the table you can see a vertical line passing with 
it, select the place you want to split and click on the mouse left button 
 

3) After you split the two columns you can select each one of them and change its 
data Type, rename column title 

 
After splitting column to two 

 
 

4.7 Leading and Trailing Spaces 
 
Leading and Trailing Spaces are kept by default. For each column in table, we can specify 
these two options: 
 

1) Remove Trailing Spaces – Spaces after the value will be removed 
2) Remove Leading Spaces – Spaces before the value will be removed 

 
Note: Option remove trailing and leading spaces are not displayed in the BRC step 2 - user can only see it 
when converting the report later on. 

 
To specify this option on a column: 
 

1) Right Mouse Click on a column and select 
 
a. Remove Trailing Spaces 
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b. Remove Leading Spaces 

 
2) On the output file for this column spaces before or after the value won’t be 

displayed, depending on the option you selected 

 
4.8 Rearrange 

 
In BRC step 3 you can re arrange the columns displayed in the resulting table 
 
To do this: 

1) In BRC step 3, under Rearrange columns box, click and hold the mouse on the 
column you want to re arrange 

2) Move up/down to where you want it to be displayed 
 
Note: You can also use the two buttons: Up/Down 

 
4.9 Sort 

 
You can sort the data in the table by different options using BRC step 3, this will affect 
the data being displayed sorted in Excel mode only 
 
To Activate Sorting: 
 
- Sort By: Sort by three columns at once 
- Ascend/ Descend: For each column you want to sort by it, you can specify if Ascending or 

Descending 
- Case Sensitive: Will cause the data to be sorted into Small and Capital Litters as differenced 
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4.10 Rename column 

 
Column names can be renamed. You can do this in BRC step. Right mouse click on the 
column -> select Rename, change the current name to whatever you specify: 

 
5 Floating Headers 

 
5.1 Introduction 

 
5.1.1 What is Floating Header 

 
Tabular reports may in some cases have data that does not come in the shape of title, header or 
detail. This is usually sub-headers, sub-titles, sub-totals.  All of these entities are defined as “floating 
headers” in RBC and need to have special treatment.  
 

 
 

Floating Header 



B2Win 7 

Implementation Guide 

NAZDAQ – Nazareth Data Quest Ltd. 

 

Page 24 of 42 
 

5.1.2 Label 
 
Floating headers have two parts: label and value. The label is the string key that BRC will need in 
order to recognize the floating header. In the above example, the floating label is “Item /Cont.:” 

 
5.1.3 Value 

 
The value of the floating header is the changing field related to the floating header’s label. The first 
value in the example above is “12610” but different values may appear towards the rest of the 
report.  

 
5.1.4 Relation between Label and Value 

 
The label and value of a certain floating header may appear on the same line. This is the most 
common use of floating headers.  
 
In more complex scenarios, the label and the value are not next to each other. The rule we need to 
keep is to have a fixed distance between them, in rows and columns.  

 

Example: 

 
In this report we want the label Report information (Marked in Red rectangle) to have the value in another line 
(Marked in Blue rectangle) 
 

1) Set Floating Label: We mark Report Information text and Right mouse click on the marked text and 
select: Floating Headers -> Add Floating Label (Label Text will be underlined) 
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2) Set Floating Header Value: We mark the Value text and Right mouse click on the marked text and 
select: Floating Headers -> Add Floating Value (Value will be colored in Italic Red) 

 

 
In the following example, the value is always 4 lines under the title and the beginning of value is 21 
columns to the left of the beginning of the label. 

 

  



B2Win 7 

Implementation Guide 

NAZDAQ – Nazareth Data Quest Ltd. 

 

Page 26 of 42 
 

 
5.2 Floating Header Types 

 
5.2.1 One-Line Floating header 

 
This floating header has the label and value on the same line. This is the common type of floating 
headers. 
 
The following example has at least 3 floating headers – all one-line floating headers:

 
In this report we want to put the Order label into a column on the main table we have for the report 
 
1) Set Floating Label: We mark Order text and Right mouse click on the marked text and select: Floating 

Headers -> Add Floating Label (Label Text will be underlined) 

 
2) Set Floating Header Value: We mark the Value text and Right mouse click on the marked text and select: 

Floating Headers -> Add Floating Value (Value will be colored in Italic Red) 
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After Label and value are set correctly the following screen appear:

 
Floating header of one line value (we specify action Pivot Down (R), we will review this in the coming sections) 

 

In BRC Step 2 we can see a column named Order 
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5.2.2 Multi-Line Floating Header with Single Label 
 
A floating header may contain a multi-line value for a label. 
 
Example: 

 
In this report “Address” is the label while the value is located in 5 lines. 
 
1) Set Floating Label: We mark Address text and Right mouse click on the marked text and select: Floating 

Headers -> Add Floating Label (Label Text will be underlined) 
 

2) Set Floating Header Value: We mark the first line of the Value text and Right mouse click on the marked 
text and select: Floating Headers -> Add Floating Value (Value will be colored in Italic Red) 

 

3) On the left panel: Select the floating header we created, and insert Value Lines: 5 (The 5 Lines of the value 
will be colored in Italic Red) 
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After Label and value are set correctly, the following appears 

 
Floating header with multi lines value specified, BRC mark value lines in red 

 

5.2.3 Multi-Line Floating Header with Repeated Label 
 
A different type of floating header is the one where the label is repeated in every line, next to the 
value, and we have a variable number of lines for this floating header.  
 
Example: 

 
Report having floating header with repeated label 
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In this report we have text that appears for every line item. The number of lines for each text is 
variable. We define here a floating header with repeated label of spaces. 
 

1) Set Floating Label: We mark the first Spaces text and Right mouse click on the marked text and select: 
Floating Headers -> Add Floating Label (Label spaces will be underlined) 
 

2) Set Floating Header Value: We mark the first line of the Value text and Right mouse click on the 
marked text and select: Floating Headers -> Add Floating Value (Value will be colored in Italic Red) 
 

3) On the left panel: Select the floating header we created, and insert the maximum number of lines for 
this label. Value Lines: 2 (The 2 Lines of the value will be colored in Italic Red) 

 
4) Select repeated Option: On the left panel select the floating header we created and check Repeated 

Label 

 
After Label and value are set correctly: You can set Floating Header Options for this floating 
header 
 

 
Floating header with multi lines value specified, and repeated label option checked 

 
5.2.4 Floating Header with Anti-Label 

 
Sometimes, it is hard to define a label for a floating header and it is easier to define an anti-label, 
which means, that when label does not equal to a specific term, recognize this as a floating header.  
 
The following is an example: 
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By defining the “:” as a floating label from type “anti-label” that does not equal to “|”, all lines that do 
not contain “|” in this specific column (Column 52) will be deleted.  

Does not Equal 
“|” 
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5.3 Actions on Floating Headers 
 
After we have defined our floating headers properly, we decide the action we want to perform on the 
floating header.  

 
5.3.1 Keep 

 
We use this option when we wish to keep the floating header (Label and value) in the same place it 
appears. 
 

5.3.2 Delete 
 
When this option is specified the label and value of the floating header will be removed from all 
report pages 
 

5.3.3 Delete Value 
 
This option keeps the label wherever it appears in the original report, but deletes the specified value 
in all its instances. 

  



B2Win 7 

Implementation Guide 

NAZDAQ – Nazareth Data Quest Ltd. 

 

Page 33 of 42 
 

 
5.3.4 Pivot Down (R) 

 
When we specify the option of Pivot Down R (Repeated), the floating header value will be repeated 
for all rows that appear after the floating header.  
 
Example: 

 
On the first rectangle for every row, Order value will be repeated 

and the same thing for the second rectangle 

 
In BRC step 2: 

 
Here we see that Order appears in every row with the same value, until another  

Order value is found in report 
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5.3.5 Pivot Down (S) 
 
When Pivot down S (Single), the value will be assigned to the rows that appear after the floating 
header, but will be repeated only on the first row for detail lines coming after as seen in the following 
(Same report like 5.3.4) 
 
Example from step 2 of the BRC: 

 
Pivot Repeated for first of detail raw only. 
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5.3.6 Pivot Up 
 
When Pivot Up is used, the value will be assigned to the rows that appear before the floating header, 
but will be repeated only on the last row for detail lines coming after as seen in the following 

example report: 

 
 
In this example we want Product Code label to be related to the upper data that is marked in Green, 
so we use the Option: Pivot Up here. 
 
In every instance of Product Code label, it will be auto related to the upper data of it. 

 
5.3.7 Rename 

 
As many times the floating header label will become a title in the resulting table, we have the 
possibility to rename it to a more meaningful name. 
 
Note: You can only rename Column name description from Step 1, in Step 2 you do not have the 
possibility to rename pivoted columns. 
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5.3.8 Change Data Types 
 
Using this option we can force certain data types for values that will be pivoted into Excel, instead of 
relying on the automatic data type assigning. 

 

 
5.4 Additional Options 

 
5.4.1 Priority 

 
We may have multiple floating headers in one report. To avoid conflict and one floating header 
“winning” over the other, we can assign a Priority for a Floating Header in a report, that cause BRC to 
search for the highest priority first – before it handles the lowest priority floating headers 
 
In this example, Red rectangle mark the first label, Green rectangle is the second label 
 
We see that in the second (Green) rectangle, also the first (Red) label also answer the same pattern, 
but our desire is that the green label to be parsed and processed first. 
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To do this in BRC: 
 

1) Mark the first Floating Header Label (In example the one marked in Red), and mark the value 
 

2) Mark the second Floating Header (In Example the one marked in Green), and its value 
 

3) To Activate Floating Header Priority, go to: Options -> Enable Floating Label Priority 

 
4) A new two buttons displayed under Floating Headers box on the left side pane, select the Floating 

Header you want to raise its priority. 

 
5) Click on Up button, to place it on the right priority according to your needs 

 
6) You can also lower priority using Down button 

 
Note: If you enable Floating Label Priority option it will be enabled for all floating headers 
set inside this report. 

 
5.4.2 Area 

 
Floating Headers may appear in every part of the report, but we may wish to limit it to a certain part 
only, in order to avoid conflict.  
 
When selecting a floating header under Floating Headers table, you can select the part where this 
floating header should appear in the report: 
 
All – In all the report  
Title – Only in the title (See Report Parts -> Title) 
Detail – Only in the details area (See Report Parts -> Details) 
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If we set a floating header to be in Detail, and there is a certain match for it in inside the Title area, BRC won’t 
parse it when it sees it in the title at all. 
 

5.4.3 Keep rest of Floating Line 
 
By default, all characters outside the floating header label and value that are on the same line where 
the floating header is active will be automatically be deleted in the resulting table. When this option 
is set, these values will be kept. 
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6 Transpose Reports 
 

6.1 Introduction 
 
Some reports are line reports (the data is not in columns) and need to be converted to Excel as columns, as in 
the following example: 

 

 
To configure this report in BRC: 
 
1) In BRC window select Report Type: Transpose 

Note: If we set Transpose Type, if you have set Floating Headers before, they will be removed 

 
The default delimiter for such reports is “:” – but it can be changed 

 
2) After that, you need to select the first line of data (including the dash-line) and assign it as the Header-Line (usually it 

is automatically selected) 

 
3) In the following example, you can see that in one line there should be three columns, thus you should group part of 

the line as a column, and then all the lines underneath will be grouped automatically (the first 9 lines will be colored, 
but all the data will be converted). 
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Assign the first column grouping 

 
Assign the second column grouping 

 
4) After you finish assigning all the parts, click on Next.  In this next step you can rename and delete any column you 

want and define data types (Split is not available in Transpose). When you are finished, click on Save and Exit.  
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7 Templates 
 

B2Win Report Customizer can assign Excel Template to the report after it has been 
customized into a table, ready to go to Excel. Templates can be loaded from the server 
or from local directory on your computer 

 
Example of setting a template: 
 
1) On BRC step 3, select a template from the list Excel Templates 
2) To Refresh preview click on the button Refresh Preview on the left bottom of the screen 

 
Note: In order to use your pre made Template: 
 
1) Click on File -> Get Local Templates 
2) Browse for an Excel template that you created 

 
Note: If you specify a template from your local directory, it is better to choose a shared directory, if you 
wish for this template to be available for the rest of the users of the customization. 
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8.0 Legal Notice and addresses 
 
Warning 
 

By installing this demo version, you are licensing this software for an initial thirty (30) 
day evaluation period only.  
 
To receive a copy of the full NAZDAQ license agreement, please contact: 
 info@nazdaq-it.com. 
 
Special Requirements 
 
Excel & Word features require Office 2000 and higher. PDF feature requires Acrobat 
Reader 5.0 and higher 

Trademarks 
 
B2Win is a company trademark of NAZDAQ Ltd. 
All other referenced company and product names may be trademarks or registered 
trademarks of others. 
 
NAZDAQ 
 
For support, please send examples/ print screens to info@nazdaq-it.com 
 
Phone +972-4-608-0023 
Fax  +972-4-647-0112 
 
Our office hours are Monday – Thursday from 10:00 until 19:00 and Fridays from 10:00 until 
17:00 (GMT+2) 
 
Check our WEB site for other Baan and ERP Ln related products: http://www.nazdaq-it.com 
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